Back to overview
Degraded

Service Notice: Email Delivery System Issues

Mar 26, 2026 at 10:53pm UTC
Affected services
Incident Management

Resolved
Mar 26, 2026 at 11:46pm UTC

The outage impacting the Incident service has been resolved. Systems are now functioning normally. Thank you for being so patient while we worked on this.

Created
Mar 26, 2026 at 10:53pm UTC

Service Notice: Email Delivery System Issues

We are currently experiencing issues with our email delivery system.
Affected features: Reset Password, Delay on login attempt failure
Our team is working on a fix. Thank you for your patience.