Back to overview
Degraded

Scheduled Maintenance Notification

Apr 1, 2026 at 4:00pm UTC
Affected services
Device Registration services

Resolved
Apr 1, 2026 at 5:40pm UTC

scheduled maintenance to upgrade core systems and enhance overall platform performance activities has been completed successfully and all services working fine. We value your understanding and cooperation. Thank you for your support.

Created
Apr 1, 2026 at 4:00pm UTC

We will be performing scheduled maintenance to upgrade core systems and enhance overall platform performance.
Maintenance Window
Date: April-1, 2026 (PT) / April-1, 2026 (KST, IST)
Start Time: 9:00 AM PT (April-1) / 11:59 AM ET (April 1)
Duration: Approximately 90 Min
Impact
During this maintenance period, login and Device Registration services will partially impact, ensuring minimal disruption to your activities. We value your understanding and cooperation. A follow-up notification will be sent once the maintenance is complete.